I was able to install on WP 2.8.6, but got a similar line 171 error when it first tried to update. Tried deleting the plugin and reinstalling, but reinstalling reported a crash.

Really liked it while it worked though :) Hopefully you can get it sorted out